Getting Subclipse in Aptana te werken met de nieuwste versie van Subversion

stemmen
34

De versie van Subclipse (1.2.4) die momenteel beschikbaar zijn door middel van automatische Aptana's Plugins Manager werkt niet met de nieuwste versie van Subversion.

Ik zie op de Subclipse website echter dat zij 1.4.2 uit voor Eclipse. Dus voegde ik een nieuwe update plaats op afstand aan mijn update manager. Toen ik probeerde om het te installeren, dan vertelde me dat ik nodig had Mylyn 3.0.0 . Dus na veel zoeken vond ik Mylyn 3.0.0 en voegde nog een nieuwe update website op afstand aan mijn Update Manager. Toen ik probeerde te installeren dat, het vertelde me dat ik nodig had org.eclipse.ui 3.3.0 of gelijkwaardig.

Kijkend naar de configuratie-informatie voor Aptana, het lijkt erop dat het is gebouwd tegen verduistering 3.2.2.

Weet iemand of er een manier om de versie van Eclipse Aptana die is gebouwd tegen te 3.3.0 upgraden? Of als er een andere manier om Subclipse te werken met de nieuwste versie van Subversion?

Ik weet dat dit niet per se een programmering vraag, maar ik hoop dat het is ok want het is zeer relevant voor de programmering ervaring.

De vraag is gesteld op 01/08/2008 om 14:56
bron van user
In andere talen...                            


4 antwoorden

stemmen
6

Ik heb problemen met JavaHL in Eclipse Ganymedes, wanneer het werkte prima in Eclipse Europa gehad. Ik ben niet zeker hoe Aptana is anders, maar probeer te upgraden JavaHL of over te schakelen naar de pure-java SVNKit implementatie binnen de Subclipse config.

antwoordde op 01/08/2008 om 15:41
bron van user

stemmen
3

Ik gebruikte de update url en ik de JavaHL adapter, het Subclipse project zelf geïnstalleerd en de SVNKit adapter BETA.

Hierna is het werkte prima voor mij, dit is voor Linux-platform hoop dat het voor u werkt.

antwoordde op 26/08/2008 om 14:41
bron van user

stemmen
4

als je niet gaat gebruiken mylyn gewoon uitvinken die afhankelijkheid. Ik ben niet echt bekend met Aptana, maar in eclips u kunt uitbreiden wat wordt geïnstalleerd en schakel alles wat je niet nodig hebt.

antwoordde op 29/08/2008 om 00:47
bron van user

stemmen
16

Subclipse vereist geen Mylyn, maar de update site bevat een plugin die Mylyn en Subclipse integreert. Dit is bedoeld voor mensen die Mylyn gebruiken. In uw geval, zou je gewoon wilt de-selecteren Mylyn in het dialoogvenster Update.

Subclipse vereist ook Subversion 1.5 en de bijbehorende versie van de JavaHL inheemse bibliotheken. Ik heb de start geschreven van een FAQ om mensen te helpen begrijpen JavaHL en hoe het te krijgen. Zie: http://desktop-eclipse.open.collab.net/wiki/JavaHL

antwoordde op 15/09/2008 om 14:26
bron van user

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more